中国教育和科研计算机网
EDU首页 |  中国教育 |   高校科技 |   教育信息化 |   CERNET
教育信息化

资讯 | 专题 会议 观点 专栏 访谈 企业 产品 CIO 技术 校园信息化 下一代互联网 IPv6视频课堂

中国教育网 > 教育信息化
您现在的位置: EDU首页 > 教育信息化 > IPv6
IPv6组播在有线网络上的研究 提出下一步研究思路
http://www.edu.cn   2008-05-22 作者:孙韬敏;王华

字体选择:【大】 【中】 【小】

  MSC与Xcast有几个不同:第一,有MSC在Internet骨干网上利用单播转发组播包,而大区通信网和存取网络中还使用现有的域内组播路由机制,第二,MSC只依赖现有的IPv6协议(特别是IPv6路由头部)而不是增加新的协议。使用MSC时每个接收者的单播地址存储在每个包中。发送方可能是MSC终端或者网关,将生成所有组成员的单播地址列表,并把最近的一个放在IPv6目的地址上。所有其他的成员地址存放在MSC路由头部,以距离发送方的远近来排序。组的组播地址也应该存储在路由头部。另外,与Xcast相比,MSC在网关之间不要求通道,因为缺少MSC功能的路由器可以根据IPv6目的地址简单地转发数据报;MSC允许应用程序使用原始IP组播,网关只需要插入MSC路由头部,而不是像在Xcast中做完全的地址映射,因此相同的组播地址可以用在不同的站点,而不需要同步网关。这些说明MSC比Xcast的引入和使用要方便。与MSC相似的基于IPv6的机制也已提出,但它们没有提出携带组播地址[17][20]。

  MSC存在的问题也不容忽视,比如IPv6路由头部产生随着组增大而产生的负载;MSC是仅IPv6的,要求MSC网关和路由器支持IPv6;所有的发送方需要知道组成员的IPv6单播地址;通过避免使用组播地址来减小路由表的大小,MSC增加了路由过程的复杂性:当处理一个MSC数据报时,MSC路由器必须执行多重查找,其中要找包中携带的每个单播地址。还有,路由器不能简单地生成数据报的拷贝,但还要保证每个包只包含通过特定接口可以到达的地址。

  4.4 利用状态分布建立组播树

  这个方法的基本思想是利用网络拓扑得到更好的分配状态,进而优化IPv6网络资源利用率,同时在这个过程中建立组播树[21]。

  当前Internet在主机之间路径计算的标准是利用最短路径,这可以由低层单播路由协议提供。在本地节点x上建立到根y的树,状态分配函数的定义如下:

  如果从x到y有不止一条最短路径的下一跳,那么在树建立的时候,选择具有最少组播状态的下一跳,如果出现相等的情况,选择默认的下一跳。

  使用这个分配函数能明显降低存储在重负载节点上的状态数量,代价是拓扑上状态总量的少量增加。但是,这种方法的前提是事先获得整个网络的拓扑信息,而且它的重点在于使状态分配更合理,以优化IPv6网络资源利用率,因此对组成员的管理及减少组播包的复制等问题有所忽略。

  5  总结

  当前对组播服务应用的需求和新Internet协议IPv6的要求促进了IPv6组播技术的研究。目前研究多集中在Internet组播地址结构及选址问题、组播路由协议及算法上。在原有组播协议及算法的基础上,采用不同的地址结构或选址方法,并进行相应的改进,是研究新协议或算法的一种便捷思路。通过描述目前IPv6组播研究算法或协议,分析其优缺点,本文希望能启发和推动下一步IPv6组播技术的研究,从而进一步解决IPv6组播现有的管理和部署难题。

  参考文献:
  [1]  S. Deering and R. Hinden, Internet Protocol, Version 6 (IPv6) Specification, RFC 2460, Dec. 1998.
  [2] Chris Metz and Mallik Tatipamula, A look at native IPv6 multicast, Internet Computing, IEEE, July-Aug. 2004, Volume: 8,Issue: 4 pp 48- 53
  [3]  Paul Smith, Laurent Mathy, Roberto Canonico, ALM and ProgNets for v4-to-v6 Multicast Transition, IEEE OpenArch Short Paper Session, pp. 11{14, Anchorage, Alaska, USA, April 2001
  [4]  M. Baneld, P. Smith, D. Hutchison and H. Leopold, Application-Level Multicast as a Transition Mechanism Towards IPv6, 23rd July 2001
  [5] Rolland Vida, Luis Costa, Remi Zara,et al. Multicast Listener Discovery Version 2 (MLDv2) for IPv6, 50th IETF Meeting <draft-vida-mld-v2-00.txt>, March 2001
  [6]  R. Hinden and S. Deering, Internet Protocol Version 6(IPv6) Addressing Architecture, Internet Eng. Task Force RFC 3513, Apr. 2003; www.ietf.org/rfc/rfc3513.txt.
  [7]  Internet Protocol Version 6 Multicast Addresses, Internet Assigned Numbers Authority assignment, May 2004; www.iana.org/assignments/ipv6-multicast-addresses.
  [8]  Jayesh M Patel S/O Maganlal, Shamsul Sahibuddin, Reliable multicast service with IPv6 support-synchronous collaborative applications, Research and Development, 2002. SCOReD 2002. Student Conference on, pp 468- 4
  [9]  P. Savola, Overview of the Internet Multicast Addressing Architecture, Internet Engineering Task Force, March 3, 2006, draft-ietf-mboned-addrarch-04.txt
  [10]  W. Fenner, Internet Group Management Protocol, Version 2, Internet Eng. Task Force RFC 2236, Nov. 1997; www.ietf.org/rfc/rfc2236.txt.
  [11]  B. Cain et al., Internet Group Management Protocol, Version 3, Internet Eng. Task Force RFC 3376, Oct. 2002; www.ietf.org/rfc/rfc3376.txt.
  [12]  Asaeda H, Suzuki S,MLDv2 Protocol Design Implementation and Evaluation for Source-Specific Multicast over IPv6, Applications and the Internet Workshops, 2003. Proceedings. 2003 Symposium on, 27-31 Jan. 2003, pp 244- 249
  [13]  Stig Venaas, Tim Chown, Source Specific Multicast (SSM) with IPv6, 2005 http://www.6net.org/publications/papers/uos-ssm-saint2005.pdf
  [14]  B. Fenner and D. Meyer, Multicast Source Discovery Protocol (MSDP), Internet Eng. Task Force RFC 3618, Oct. 2003; www.ietf.org/rfc/rfc3618.txt.
  [15]  B. Haberman and D. Thaler, Unicast-Prefix-Based IPv6 Multicast Addresses, Internet Eng. Task Force RFC 3306, Aug. 2002; www.ietf.org/rfc/rfc3306.txt.
  [16]  马戈芳,徐明伟,IPv6组播技术综述,电信技术,2003 No.7 P.23-26
  MA G F, XU M W. Overview of IPV6 Multicast Technology. Telecommunications Technology 2003 No.7 P.23-26
  [17]  R. Boivie et al., Explicit Multicast (Xcast) Basic Specification, Internet draft, work in progress, Jan. 2003.
  [18]  Myung-Ki Shin, Ki-Il Kim et al. Multicast delivery using explicit multicast over IPv6 networks, Communications Letters, IEEE, Feb 2003, Volume: 7,Issue: 2, pp 91- 93
  [19]  Stefan Egger,Torsten Braun, Multicast for small conferences A scalable multicast mechanism based on IPv6, IEEE Communications Magazine, January 2004
  [20]  I. Yuji, Multiple Destination Option on IPv6 (MDO6), Internet draft, raft-imai-mdo6-01.txt, work in progress, Mar. 2000.
  [21]  Mickal Hoerdt,Damien Magoni, Distribution of multicast tree states over the IPv6 network topology, Communications, 2004 IEEE International Conference on, 20-24 June 2004, Volume: 4,pp 1991- 1995 Vol.4

  作者简介:
  孙韬敏(1981-),女,山东济南人,硕士研究生,主要研究方向为网络路由与组播。
  王华(1962-),男,山东济南人,博士后,山东大学副教授,主要研究方向为网络优化算法,网络路由与组播。

页面功能 【打印】 【关闭】 【我有话说】

MOOC风暴来袭

版权所有:中国教育和科研计算机网网络中心 CERNIC,CERNET,京ICP备15006448号-16,京网文[2017]10376-1180号

关于假冒中国教育网的声明 | 有任何问题与建议请联络:Webmaster@staff.cernet.com